Chapeau 23 Beta input freezing and Steam not working

Off

Home Forums Issues & support Chapeau 23 Beta input freezing and Steam not working

Tagged: , , ,

This topic contains 3 replies, has 2 voices, and was last updated by  knight2_6 1 year, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2101

    knight2_6
    Participant

    Hello,

    I just recently installed Chapeau 23 Beta. I had an installation of Fedora 22 Xfce previously but I decided to try to Chapeau since it is based on Fedora with just about every program I would want already included in the package. I tried to install Chapeau 22 but I couldn’t get it to boot after the installation process for some reason so I downloaded 23 beta to try it. I successfully installed and booted 23 beta but I seem to be having some input issues. The mouse and keyboard seem to loose connection if I every stop typing or moving the mouse for more than a few seconds. The mouse won’t respond until I click a button a few times and it’s the same for the keyboard. I also can’t get steam to open either. I would appreciate any help. I’m a beginner when it comes to Linux. My main Windows gaming system is down right now waiting on some parts so I thought I would take the time to try another Linux distribution on my testing system while it’s down. System hardware specs below.

    CPU: i7 3770K
    RAM: Crucial 8GB
    GPU: AMD Radeon R9 290
    HDD: Seagate 500GB

    #2102

    Vince
    Keymaster

    Hi knight,

    Firstly I suspect the problem you’re having with Steam is being caused by a known issue with the Steam package which is attributed to you having an AMD GPU.
    Your solution is here until Steam gets fixed, there is a bug report at the RPMFusion bugzilla here.

    Your USB issue I would guess to be be a kernel/power saving config issue with the Fedora 23 kernel which is causing your USB devices to go into standby.
    Do you have many USB devices connected? Try disconnecting all but the keyboard & mouse and see if the problem goes away. It may be a particular USB device triggering the problem.

    Alternatively when you’re experiencing the issue reconnect your input devices, open a terminal and run;
    cat /sys/bus/usb/devices/*/power/control
    .. this will likely show a list of mostly auto?

    You can temporarily disable the power management on all your USB devices by running the following in a terminal;
    for a in /sys/bus/usb/devices/*/power/control ; do echo on | sudo tee $a ; done
    … and see if the problem goes away. This will not last a reboot though but there’ll be a way of making it permanent.

    A quick search of the Red Hat/Fedora Bugzilla reveals this bug that may be what you’re seeing?

    Let us know how you get on.

    Vin

    • This reply was modified 1 year, 10 months ago by  Vince. Reason: forgot link
    #2110

    Vince
    Keymaster

    Ok..

    So I’ve managed to replicate this on one of my desktop PCs and it appears to be a nice default ‘feature’ of the powertop package. It now has a daemon that switches everything to auto-suspend including all USB devices.

    Uninstalling the powertop package should fix your issue. In a terminal…
    sudo dnf remove powertop
    .. and your input devices should be OK next boot.

    I’ll remove powertop from Chapeau’s default package set for now.

    Thanks for posting your issue,

    Vin

    #2113

    knight2_6
    Participant

    Alright, thanks for the help. Removing powertop took care of the the input issue and I have steam running. It does give me a warning in a xterm window when it loads stating that the steam package is out of date. I’m installing some steam games to do some performance testing.

    Thanks again,

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.